A place for Wisconsin 240sx owners and enthusiasts to meet.
 
HomeRegisterLog in

Share | 
 

 sr20det cranks but wont start

View previous topic View next topic Go down 
AuthorMessage
sil_sr20
Be nice, I'm new
avatar

Posts : 9
Join date : 2012-06-30
Location : Madison

PostSubject: sr20det cranks but wont start   Sat Jul 07, 2012 10:59 pm

Hey people, I'm kinda at a loss here . I just dropped a s13 Sr motor in my 95 240sx "e5" eccs. I just moved and this car is still sitting in my old houses garage, I got 2 days to get it outa there so I'm obviously in go mode with this thing. I've spent bout 20 hours in the last 2 days trying to make it go Haha...anyways I just rewired everything cause it was a mess so I know all the mechanical works. But now when I try to start it, it will crank but not start. I got fuel I got spark I have evrything unloomed and am 99% positive its all wired correctly I have all the swap guides and have researched the shit out of every plug and wire in that car and am stuck right now....any help/suggestions would be awesome since I'm in a huge rush to make it drivable so I don't have to rent a flat bed. Thanks
Back to top Go down
tacozzz
Junior member


Posts : 32
Join date : 2011-08-31

PostSubject: Re: sr20det cranks but wont start   Sun Jul 08, 2012 12:42 am

if you have fuel and u have spark, check the compression...assuming you didnt tear into the motor, it should be fine, but check it anyways...then check the timing

there are 4 things you need to run an engine,

1. fuel
2. spark
3. compression

and they all have to come together at the right time

4. timing

if all that is correct, go back and double check everything,

fuel:
are u getting fuel pressure to the injectors (fuel pump good?, fuel filter clogged?)
are u getting the right sensor readings for the tps, maf, cas, o2 , cts
then check your neutral switch/at controller make sure it sending the right signal to the ecu

ignition:
are your spark plugs gapped right
are u getting priliminary/secondary power to your coils (relay burnt out?,transistor fried?)
if your tps,maf,cas,cts, and vss sensor checked out alright, now check your knock sensor<--important
compression test
then,
check timing


hope that helps
Back to top Go down
sil_sr20
Be nice, I'm new
avatar

Posts : 9
Join date : 2012-06-30
Location : Madison

PostSubject: Re: sr20det cranks but wont start   Thu Jul 19, 2012 12:44 pm

hey thanks for all the help man, I had actually tried all of that b4 you even posted it up with no luck but it's always good to hear a 2nd opinion. anyways after getting flat bedded to the new house. started to dig in a little deeper and the cable for the starter had come loose and wasn't making a good connection.."SMH" facepalm... I dont know why but its always the stupidest little shit that gets over looked when I have problems like this. but yeah tightened that down and the car runs perfect Smile
Back to top Go down
600SX
Admin
avatar

Posts : 2510
Join date : 2010-08-19
Age : 36
Location : Twin Lakes

PostSubject: Re: sr20det cranks but wont start   Thu Jul 19, 2012 1:00 pm

Glad it's fixed. It's always smart to start with the easiest stuff first, next time you'll know.

_____________________________
Stupid hippie,  This IS a Hybrid

I AM THE ANTI-PRIUS
Back to top Go down
sil_sr20
Be nice, I'm new
avatar

Posts : 9
Join date : 2012-06-30
Location : Madison

PostSubject: Re: sr20det cranks but wont start   Thu Jul 19, 2012 1:17 pm

yeah, after doing this much work to a car in such a short time you tend to look for the bigger problems rather than the stupid stuff first, but yeah I'm happy its all good and it's pretty happy sitting in the new garage

[img][You must be registered and logged in to see this image.][/img]
Back to top Go down
Sponsored content




PostSubject: Re: sr20det cranks but wont start   

Back to top Go down
 
sr20det cranks but wont start
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Wisconsin240sx :: Tech-
Jump to: