A place for Wisconsin 240sx owners and enthusiasts to meet.
 
HomeRegisterLog in

Share | 
 

 o2 sensor ?

View previous topic View next topic Go down 
AuthorMessage
feyd_w
Member


Posts : 110
Join date : 2011-02-04
Age : 26
Location : osceola Wi

PostSubject: o2 sensor ?   Sat Feb 05, 2011 8:09 pm

ok the o2 sensor is just chilling in my car, the wire to plug it in is non existant, not the wire on the o2 sensor it self but the other part. its running like crap right now, i guess im just wondering how i can get it connected?
Back to top Go down
s13.240sx
Senior member
avatar

Posts : 1113
Join date : 2010-10-01
Age : 104
Location : Menomonee Falls

PostSubject: Re: o2 sensor ?   Sun Feb 06, 2011 10:49 am

Which engine do you have? And the connector for it should be somewhere near the exhaust manifold side of the engine(obviously). I believe most of the nissan engines have a clip or bracket that it mounts to somewhere by the valve cover near the rear of the engine. If the O2 sensor is not hooked up it will cause the engine to run in a fail safe mode which will be very rich. Also a faulty Knock sensor will cause it to run really bad as well. The Knock sensors are notorious for going bad on many nissan vehicles, not just the 240. If the O2 sensor is bad/not connected it will run ok when you start a cold engine, because the sensor has not warmed up enough to properly monitor anyhing yet.
Back to top Go down
feyd_w
Member


Posts : 110
Join date : 2011-02-04
Age : 26
Location : osceola Wi

PostSubject: Re: o2 sensor ?   Sun Feb 06, 2011 11:24 am

yea its a fresh ka24de with like 70k on it, i was looking around for the clip but i couldnt find anywhere, the only thing that it fit in was way up by the headlights. i dont think it was that.
Back to top Go down
pancho y onions
Senior member


Posts : 156
Join date : 2010-12-17

PostSubject: Re: o2 sensor ?   Sun Feb 06, 2011 7:06 pm

It's a single wire that runs behind the head closer to the fire wall. Usually has a plastic shield around the wire.
Back to top Go down
pancho y onions
Senior member


Posts : 156
Join date : 2010-12-17

PostSubject: Re: o2 sensor ?   Sun Feb 06, 2011 7:07 pm

It's a single wire that runs behind the head closer to the fire wall. Usually has a plastic shield around the wire.
Back to top Go down
feyd_w
Member


Posts : 110
Join date : 2011-02-04
Age : 26
Location : osceola Wi

PostSubject: Re: o2 sensor ?   Wed Feb 09, 2011 5:16 pm

ah this is driving me crazy, i cant find it anywhere, and i dont see anywhere on the wiring harness where it could have been cut from. how hard would it be to wire a new one in? or should i just try to find a whole new harness
Back to top Go down
ohhhizzzy
Senior member
avatar

Posts : 805
Join date : 2010-08-20
Location : Delavan wi

PostSubject: Re: o2 sensor ?   Wed Feb 09, 2011 5:18 pm

if the clip is not there is easy to solder one in but if you cant find the cable u might need a new harness
Back to top Go down
s13.240sx
Senior member
avatar

Posts : 1113
Join date : 2010-10-01
Age : 104
Location : Menomonee Falls

PostSubject: Re: o2 sensor ?   Thu Feb 10, 2011 6:58 pm

If you are not afraid to dig into wiring a little it wouldn't be too touogh to add. All you need to do is find a diagram for the ECU harness pinout with the color codes for the wires as well. Check to see if there is at least the wire coming off of the connector for the ECU. If it is then you can either try to find that same wire in the engine compartment dangling or cutoff. Or you could just clip it at that point (a feww inches off of the back of the connector), get a soldering gun and some heat shrink tubing and run a new wire yourself from the ECU to engine compartment. Then either put male and female insulated spade connectors on at that point or repaet the soldering process(more of a hasle for future replacement). If this is beyond your abilitiles get a new/used harness. This will most likely be cheaper though.
Good Luck.
Back to top Go down
feyd_w
Member


Posts : 110
Join date : 2011-02-04
Age : 26
Location : osceola Wi

PostSubject: Re: o2 sensor ?   Fri Feb 11, 2011 8:26 am

thanks
Back to top Go down
s13.240sx
Senior member
avatar

Posts : 1113
Join date : 2010-10-01
Age : 104
Location : Menomonee Falls

PostSubject: Re: o2 sensor ?   Thu Feb 17, 2011 9:39 pm

So are you going to share how you resolved the problem? Even if it was something simple like you finally located the connector because you couldn't see it? scratch
Back to top Go down
feyd_w
Member


Posts : 110
Join date : 2011-02-04
Age : 26
Location : osceola Wi

PostSubject: Re: o2 sensor ?   Sat Feb 19, 2011 4:27 pm

found the sensor wire, was grounded to the block, got new sensor, fixed dizzy and injector
Back to top Go down
s13.240sx
Senior member
avatar

Posts : 1113
Join date : 2010-10-01
Age : 104
Location : Menomonee Falls

PostSubject: Re: o2 sensor ?   Sun Feb 20, 2011 8:12 am

Thats great, I love when it turns out to be an easy fix. The only other question that I havefor you is, what is a "dizzy"? I have not ever heard of a part refered to as that. Would that be the same as the Distributor?
Back to top Go down
feyd_w
Member


Posts : 110
Join date : 2011-02-04
Age : 26
Location : osceola Wi

PostSubject: Re: o2 sensor ?   Sun Feb 20, 2011 3:34 pm

ya
Back to top Go down
Sponsored content




PostSubject: Re: o2 sensor ?   

Back to top Go down
 
o2 sensor ?
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Wisconsin240sx :: Tech-
Jump to: