A place for Wisconsin 240sx owners and enthusiasts to meet.
 
HomeRegisterLog in

Share | 
 

 unhappy rb20 HELP PLEASE

View previous topic View next topic Go down 
AuthorMessage
ef1lover
Be nice, I'm new
avatar

Posts : 8
Join date : 2011-06-23
Age : 27
Location : waubeka wi

PostSubject: unhappy rb20 HELP PLEASE    Thu Jun 23, 2011 4:46 pm

ok so i am not even sure i know where to start? hello my name is Anthony i have a 1990 240sx with a rb20 i bought the car swapped but have never got it running correct what the car does is it idles ok and revs fine but when u drive the car it goes noware a 10 speed bike could pass me things i have changed i have splitfire coils, walbro pump, aem adj fpr, blitz chipped ecu, 3'' exhaust, hardpipe intake tube with hks filter the fuel pressure is set at 38-39 at idle the plugs are gapped at .8 and new i have 2 diffrent mafs 2 diffrent ignitors, 3 computers and cant seem to get the problem fixed?? with the one computer i got with the car which is a 212 computer its a chipped non turbo comuter it will idle but like i said has no power no codes just blinks 55 with the blitz ecu i get a code 11 and the other day i hade a code 21 ?? with the blitz ecu it runs like garabage wont really idle and sounds like its missing and the third comuter if i rember is a 117 so a auto turbo computer and it just keeps blinking like its blown up or in limp mode it starts up but u need to crank up the fuel pressure ?? i have no idea i am lost it makes no sense to me i am just a transmission guy if u have any idea please post or call me @ 1 262 483 9143 i would love to drive it and not have to have it stay in the garage any longer thanks for any advise u have
Back to top Go down
VNG704
Senior member


Posts : 285
Join date : 2010-09-17

PostSubject: Re: unhappy rb20 HELP PLEASE    Fri Jun 24, 2011 7:59 am

For starters, use better grammer. It's hard to make out what you're trying to say. I would find out what the error codes mean and fix them. Sometimes when people swap motors over, they do their own wiring and do it wrong or poorly. Make sure it's done correctly. In my experience with cars not running right, it's a vacuum leak or a bad MAFS or MAFS wiring. Also you can check the gap on the plugs because incorrectly gapped plugs won't let the car run too well. You did state .8 but I have no idea what it's supposed to be at. Other things that effect how the engine runs are CAS and the coils. I don't know how to check them if they're working properly, but if you can find an FSM that would help. Also google or yahoo how to's, DIYs, etc... Good luck.
Back to top Go down
240sxguy
Senior member
avatar

Posts : 609
Join date : 2010-08-19
Age : 37
Location : Madison area

PostSubject: Re: unhappy rb20 HELP PLEASE    Fri Jun 24, 2011 12:01 pm

First off, set the base fuel pressure and leave it. If you can make it run by jacking with that, then you are just masking the real problem.

Remove the blitz ecu, install the correct known working RB20 ECU.

Stock injectors?

You didn't do this swap, so you need to basically start over. Is the harness a mess?
Back to top Go down
ef1lover
Be nice, I'm new
avatar

Posts : 8
Join date : 2011-06-23
Age : 27
Location : waubeka wi

PostSubject: Re: unhappy rb20 HELP PLEASE    Sat Jun 25, 2011 12:26 am

lol thats super funny "install a good known working ecu'' if i had one i would use it lol that should b obvious i have know idea if it good or not all three computers work differently in the car how do i know which is a good know ecu there is no rb20 around here that i know yes stock inj and this is the second harness i have no idea how mad its inside i got it and threw it in the car idle the fuel press is 38 and no to the batter grammer iza dumb mechanic Smile how do i fix codes that only come up on one ecu and only run bad on one ecu ???? no vaccumm leak and maf wires ohm checkd at the ecu good new plugs gapped at .8 no idea car hates me lol
Back to top Go down
240sxguy
Senior member
avatar

Posts : 609
Join date : 2010-08-19
Age : 37
Location : Madison area

PostSubject: Re: unhappy rb20 HELP PLEASE    Sat Jun 25, 2011 9:20 am

Yeah, buy a working ECU. Having a known good working spare ECU is pretty important to have. I have a spare ECU for my car even though I have huge injectors.. for troubleshooting. Same with a cam sensor.

I don't give a shit how bad your grammar is, time for hooked on phonics. Troubleshooting a car over the internet is difficult enough without reading a wall of text.

Sorry to sound like an asshole, I will try to help you out but you have to do your part by at least making it easy to understand.

A friend of mine had a harness professionally done by a reputable company, and even they made mistakes. Nothing is guaranteed!

Evan
Back to top Go down
ef1lover
Be nice, I'm new
avatar

Posts : 8
Join date : 2011-06-23
Age : 27
Location : waubeka wi

PostSubject: Re: unhappy rb20 HELP PLEASE    Sat Jun 25, 2011 1:19 pm

ya i have no idea which ecu is working correct. i have no idea if the cam sensor works right but when u spin the cas the inj fire and the coils spark. so i think the cas works. when i unplug the maf the car shuts off and it runs the same with the other maf. is it possible i have two bad mafs for sure. i have an ecu pinout and i ohm tested all the wires. there were a lot of wires disconnected i would love to get a wire diagram for the harness and just check it myself. like for instance there is only two wires that go to the dash. there is wires missing other parts of the main ecu plug but without a full diagram its impossible to tell where they go Sad. i am trying to get another 3rd harness but thats not easy eather lol. i would rather sell the car as is for 4500 and just get out of it lol Smile
Back to top Go down
93sapphirecoupe
Senior member


Posts : 662
Join date : 2011-05-05

PostSubject: Re: unhappy rb20 HELP PLEASE    Sat Jun 25, 2011 2:24 pm

what about the tps? have you checked if thats working?
Back to top Go down
240sxguy
Senior member
avatar

Posts : 609
Join date : 2010-08-19
Age : 37
Location : Madison area

PostSubject: Re: unhappy rb20 HELP PLEASE    Sat Jun 25, 2011 4:39 pm

If you need harness pinouts go to the RB forum on nicoclub.com and I think it's stickied.
Back to top Go down
hurleyboy00
Junior member


Posts : 33
Join date : 2011-05-15

PostSubject: Re: unhappy rb20 HELP PLEASE    Sun Jun 26, 2011 10:16 am

I spoke to you in email a few days ago. You didn't mention the ECU situation... I would get the correct ECU first. I can almost guarantee that is part of the issue. Especially if you are running a NA ecu on a FI engine.

These are wrong for your car, yes it does make a difference:
R32-GtS RB20DE Manual M FR 23710-11U00 MEC-R212
R32-GTS4 RB20DET Auto 4WD 23710-04U70 MEC-R117

A RWD RB20DET needs, figure out what exact model year engine you have for best results:
R32-GTSt RB20DET Manual FR 23710-04U01 MEC-R126 27C256 (Big #22 on it) OR
R32-GTSt RB20DET Manual FR 23710-04U00 MEC-R106 27C256
R32-GtSt RB20DET Manual FR 23710-04U02 MEC-R132 27C256

After you get the correct ECU, do the timing, check the vacuum and intercooler piping. Igniter chips generally don't go bad, and if it were bad it wouldn't idle or start.
Back to top Go down
hurleyboy00
Junior member


Posts : 33
Join date : 2011-05-15

PostSubject: Re: unhappy rb20 HELP PLEASE    Sun Jun 26, 2011 10:20 am

Also, What is the part number of the MAFS sensor? Since you don't care what ECU you throw into it, I can only assume you probably just grabbed a random MAFs and stuck it in.
Back to top Go down
Sponsored content




PostSubject: Re: unhappy rb20 HELP PLEASE    

Back to top Go down
 
unhappy rb20 HELP PLEASE
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Wisconsin240sx :: Tech-
Jump to: